PDA

View Full Version : Known Forum Bugs - PLEASE READ BEFORE POSTING


Solandia
30-03-2009, 11:32
There are a few known issues with the forum software that have resulted in some bugs.

1. 65535 Unread Private Messages
2. White Screen or Fatal Error When Searching
3. Forbidden Error
4. Can't Log Out: Warning: array_merge()
5. Blank Posts or Private Messages

Solutions or workarounds are below.

1. 65535 Unread Private Messages

Problem: Private message inbox says there are 65536 unread private messages when the real number is much less.

Fix: There's no definite fix, but clearing old sent messages may correct the number.

More Info: http://www.tarotforum.net/showthread.php?t=111549


2. White Screen or Fatal Error When Searching

Bug: A fatal error or plain white screen is returned when very common words, eg 'tarot' or 'deck', are included in a search.

Fix: Leave out the common words from the search, or use the Google quick search instead of the forum's own search engine.

http://www.tarotforum.net/search.php?

More Info: http://www.tarotforum.net/showthread.php?t=113448


3. Forbidden Error

Bug: Posts containing certain words results in a 'Forbidden Error'.

Fix: Adding spaces or dashes to the word (eg. w-o-r-d) will get around the security setting. If you're still getting the error, email (email@tarotforum.net) a copy of your post to Solandia.

More Info: http://www.tarotforum.net/showthread.php?t=49173


4. Can't Log Out: Warning: array_merge()

Bug: On logging in or out of the forum, an error similar to below is returned:

Warning: array_merge() [function.array-merge]: Argument #2 is not an array in /includes/functions.php on line 3615

Unable to add cookies, header already sent.
File: /home/tarot/public_html/includes/init.php
Line: 27

Solution: Wait a few minutes and try again.

5. Blank Posts or Private Messages

Bug: On trying to post or send a private message, the post or message appears blank, even though the contents can be viewed when editing.

Solution: Check the QUOTE tags. If a bracket (the [ or ] symbol) is missing, it can render the whole post blank.