PDA

View Full Version : IE9 error -- can't access forums


yirabeth
28-03-2011, 23:10
I'm posting for BlueDragonfly (we're neighbors, more or less, and are attempting to get her back to AT) She is unable to log into the forums this morning. Her error message is as follows:

Warning: array_merge () [function.array-merge]: Arguement #2 is not an array in /includes/functions.php on line 3615

This is at the very top of the page.

The username and password boxes are there, but the log-in box isn't normal size. When I click on that, it goes to another screen with a box that says:

Unable to add cookies, header already sent.
File: /usr/home/tarotfor/domains/tarotforum.net/public_html/includes/init.php
Line: 27


Blue installed IE9 yesterday, and browsed AT with it fine. However this morning she can only get the above error.

We have of course tried deleting the cache/cookies, making sure permissions were right for cookies, etc. Web search seems to feel it's an error in that line of code (Line 27) that other browsers just gloss over but IE won't. (perhaps an extra white space.)

It has occurred to me that perhaps others (me for example) aren't getting an error because we have saved our password and have it log us in automatically which may circumvent that particular bit of code. Just a thought though; I'm not a PHP guru :)

Any suggestions on how to get this fixed?

BlueDragonfly
29-03-2011, 00:26
Hmmm... I did change my password yesterday, but I think it was after I had done the upgrade. Not 100% sure of that, though.

I'm on a borrowed laptop, right now. I didn't have a problem, I was already signed in when the forum page opened.

yirabeth
29-03-2011, 05:18
Further developments -- downloaded Firefox and got the same error -- uninstalled IE9, exact same error.

However I'm personally not having an issue, even though Blue is sitting right next to me and her laptop won't enter the site -- all forums have the lock on them. But she can go anywhere else on the internet...

BlueDragonfly
29-03-2011, 12:21
Update. HP support says that website settings changed in the program files. And that tech support on the site has to fix it. Or I can do a system restore to before the problem started.

Can it be fixed without a system restore?

Solandia
29-03-2011, 13:58
That's a bug with the forum software. I've had it before myself, and usually waiting a few moments and then logging in again fixes it.

If not, try logging in via http://tarotforum.net instead of http://www.tarotforum.net.

~ Solandia

BlueDragonfly
29-03-2011, 21:08
Solandia, Thanks for the information. I just tried the other log in addy and that didn't with either.

Tonight when I get home from work, I'll try again, clear the browsing history again, and fiddle with it some more.

I forgot to add, that the support guy removed IE 9 and installed IE 8 again.

gregory
29-03-2011, 22:35
Another forum I'm on people have been installing iE 9, cursing to all get out and uninstalling it.... I am still avoiding upgrading to 8 - not that I ever use it except for sites that won't allow anything else...

Aerin
30-03-2011, 06:49
I like 8.

I will avoid 9 for the time being though.

BlueDragonfly
30-03-2011, 09:45
All fixed! :D And I didn't have to do a thing. I checked it this morning and it still wouldn't let me log in.

I gave it one more try tonight, before I started monkeying with things and it works! Yay!